[sbopkg-users] GPG Check Failure

sbop.echo.towerboy at xoxy.net sbop.echo.towerboy at xoxy.net
Thu Oct 4 18:04:17 UTC 2012

On 10/04/2012 12:33 AM, slakmagik - slakmagik at gmail.com wrote:
> Have you tried manually checking the files? IOW, does the GPG check fail
> only within sbopkg or altogether? Because, if it isn't a configuration
> problem with gpg on your new system, I'm stumped - anything I think of
> has an equal reason for why it couldn't be that. And, if it is in
> sbopkg, could you send me a package list of what exactly you installed
> and which ones failed? Is it still continuing to fail with additional
> packages? And have you tried moving over the old repo and re-syncing?
> Also, while it shouldn't matter, there's a new sbopkg 0.36.0 out - do
> you still have problems running that version?
When I manually check the signatures of the files ( with "gpg --verify", 
as root) gpg says it can't check the signature because the public key 
does not exist.  I don't recall configuring gnupg before when I first 
used sbopkg on my laptop, but maybe I simply forgot I did something.  I 
do notice that /root/.gnupg/pubring.gpg exists on my desktop PC, but it 
has zero bytes.  On my laptop, I do have the Slackbuilds.org public key 
installed.  Does sbopkg get this key when it syncs with a remote repository?

I did copy /var/lib/sbopkg and /var/cache/sbopkg from my laptop to my 
desktop.  That's because I plan to keep the laptop up-to-date with 
sbopkg, when I'm connected to a wi-fi network, and copy changes to my 
desktop.  I have dial-up internet access at home, so it might take a 
while to update things there, plus I don't have the modem configured yet 
(awaiting a serial port), so it's not even possible yet.

It'll be a while until I can verify if the problem exists with sbopkg 
0.36.0.  I expect it will, if I don't get gpg configured properly.


More information about the sbopkg-users mailing list