[sbopkg-users] GPG Check Failure

slakmagik slakmagik at gmail.com
Thu Oct 4 04:33:51 UTC 2012

On 2012-09-30 (Sun) 23:37:55 [-0400], sbop.echo.towerboy at xoxy.net wrote:
> First of all, thanks for creating and maintaining sbopkg.  Although it's
> easy to find and install software found on Slackbuilds.org, this makes
> it even easier.

Speaking for Chess and Mauro, you're welcome - glad you like it.

> I started using sbopkg on a laptop with the 32-bit version of Slackware
> 13.37.  It works fine there.  I wanted to use it on a new installation
> of 64-bit Slackware 13.37 on a desktop PC, and I do not have the 32-bit
> libraries installed.  Instead of just copying over the 32-bit packages
> and installing them, I copied over /var/cache/sbopkg and /var/lib/sbopkg
> after installing the sbopkg 0.35.0 (if memory serves; the latest from
> 2011, anyway) package on the new PC.  I created one tar.gz file of
> /var/log/packages, since it was about 115MB, so I actually "untarred" it
> on the new installation.  When I try to compile packages I've put in the
> sbopkg queue on the new PC, though, I get an error of "GPG Check
> Failed!" and several options to do what I thought was quit.  It appears,
> however, that selecting "Yes" to keep the files lets the compilation
> continue to a successful completion, although I have yet to actually run
> any of the programs I've compiled.
> Does anyone know why the GPG check fails?  It does not fail on the
> laptop with the original installation of sbopkg, and which I synchronize
> with on-line repositories.

Have you tried manually checking the files? IOW, does the GPG check fail
only within sbopkg or altogether? Because, if it isn't a configuration
problem with gpg on your new system, I'm stumped - anything I think of
has an equal reason for why it couldn't be that. And, if it is in
sbopkg, could you send me a package list of what exactly you installed
and which ones failed? Is it still continuing to fail with additional
packages? And have you tried moving over the old repo and re-syncing?

Also, while it shouldn't matter, there's a new sbopkg 0.36.0 out - do
you still have problems running that version?

More information about the sbopkg-users mailing list